Wiring Illuminator Quick Start Guide
Wiring Illuminator Foreign Military Sales Demo
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Installing & Running Wiring Illuminator
This documents contains instructions for quickly and easily installing and running Wiring Illuminator
with the Foreign Military Sales demo database. It also takes you through some basic examples of how
to use Wiring Illuminator to view wiring information contained in the demo database.

System Requirements
The Wiring Illuminator FMS Demo requires a Windows based PC with a CD drive. Listed below are
the software requirements for the PC:


Operating System - Windows NT 4.x, 9X, 2000, XP



ODBC database drivers for Microsoft Access (most machines should already have this)



NOTE: The Microsoft Access application is *not* required on your system.



Java Runtime Environment 1.3.1_02 (Provided on the demo CD and installed automatically.)

The Microsoft Access ODBC Driver will be installed and connected to the database file (.mdb) used
by Wiring Illuminator. The database file is wifmsdemo.mdb.

How to Install Wiring Illuminator
Insert the Wiring Illuminator FMS Demo CD into your CD drive and close the drive. A window should
automatically pop and run InstallShield to install the Wiring Illuminator software and the FMSDemo
database.
When prompted for information by InstallShield during the installation process, simply select the
default options.

Documentation
A Wiring Illuminator User's Manual and a set of Release Notes will be available on your computer
after installation.
These files will be located in the Wiring Illuminator directory:
C:\wi\FMSDEMO_WI\data\documents. (This assumes that you installed Wiring Illuminator on the C
drive of your computer.)
Additionally, on-line Help is available from within the Wiring Illuminator program. From the
“Context View” window select the “Wiring Illuminator Help” menu item from the “Help” menu.

Running Wiring Illuminator
After InstallShield runs, there will be a Wiring Illuminator icon placed on your desktop. Doubleclicking the icon will launch Wiring Illuminator.
You can also start wiring Illuminator via the Windows “Start” menu. The Wiring Illuminator
application is accessed via Start->Programs->Wiring Illuminator->Wiring Illuminator.
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Selecting Wiring Illuminator Display Views
When the Context View window appears (after starting Wiring Illuminator) the Window menu can be
used to select which views are displayed. Simply check the check box for any windows that you want
displayed, or uncheck the check box for any windows you do not want displayed.
If not already displayed, a good set of default views to have displayed would be:


Wire List View - Displays a tabular view of the RefDes’, pins, and wires in the current circuit
or wire run.



Pin List View - Displays a tabular list of all of the pins and connecting wires for the current
RefDes.



Parts List View - Displays a tabular list of parts that compose the current RefDes.



Wire Diagram View - Displays a wiring diagram of the RefDes’, pins, and wires in the current
circuit or wire run. It contains a status panel that displays wire information.



Locator View - Displays a graphic of the location of the current RefDes on the aircraft or
system



Pin Arrangement View - Displays a graphic of the pin arrangement of the current RefDes.

Selecting Views To Be Displayed
Which views appear at startup, and their layout (location) on the screen, can be set by selecting the
Context View window File menu option:
File->Save Layout
This will save the current layout for use the next time Wiring Illuminator is executed.
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Standard Wire Run Examples
A wire run can be displayed by either of two methods. The first is to enter the Tail Number, RefDes
and connector Pin for a specific aircraft and wire run into the appropriate fields in the Context View
window. The second is by selecting the "Browse..." button in the Context View window and
navigating down the context tree to the desired wire run.

Selecting A Wire Run – Context View
To view a good example of a wire run via the first method (by entering the information directly in the
Context View window fields), first enter the number 165454 in the Tail Number field of the Context
View window, and hit Enter on the keyboard.
At this point, the RefDes and Pin fields will no longer be grayed out and are now available for data
input. Next enter the RefDes and Pin information below in the corresponding fields, and then press the
“OK” button. (Note: Entries are case sensitive.)
Tail Number:
RefDes:
Pin:

165454
76P-H009B
66

The screen shot below shows the Wiring Illuminator Context View window with the appropriate fields
filled in. Note that this screen shot was taken prior to the OK button being selected, so none of the
other views have any data in them yet.

Enter Tail
Number, RefDes
and Pin in Context
View

Selecting A Wire Run In Context View
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Selecting A Wire Run – Browse Function
Optionally, you can also view this same example by navigating the context tree. Click on the Browse
button in the Context View window. The Browse window will be displayed containing the high-level
Aircraft folder.

Browse
Window

Wiring Illuminator Browse Window
Now double click on the folders that are displayed in the Browse window in the order shown below.
After double clicking on the last folder (Pin 66), all of the other views will be populated with aircraft
wiring data.
AIRCRAFT
Internal
165454
Listed by RefDes
76
76P-H009B
66

-- Model of aircraft
-- Internal aircraft wiring (as apposed to pylon wiring)
-- Tail number of the specific aircraft
-- Can enter via bundle, wire, or RefDes
-- All the RefDes's beginning with the number "76"
-- RefDes 76P-H009B (some views should display data)
-- Pin 66 (all views should populate)

The screen shot on the next page shows what you will see on your screen after the views are populated
with wiring data. You may not see anything in the Locator View, and may need to adjust the vertical
slider on the right hand side of the Locator View window to view the diagram that is displayed in this
view.
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Wiring Illuminator – Standard Views
Note that any of the views can be relocated, resized or closed by using your mouse and the window
controls that are provided for each view, just like any other MS Windows application.
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Navigating To A New Wire
Navigation to a new wire can be done either by entering a new wire run in the Context View RefDes
and Pin fields (as in the previous example), or by selecting with your mouse and clicking with the left
mouse button on specific wires, RefDes, or pins in the Wire Diagram view, or by clicking on any other
hot text or graphics in the other views.
For example, in the wire diagram the focus can be switched to the wire between RefDes J6P-J008AS001 and plug J6P-J008A, pin T, by clicking on the wire in the Wire Diagram View. Using your
mouse, left-click on the wire (red wire) indicated in the screen shot below.
Note that all of the views are updated to display the data for the new wire – the Pin Arrangement View
is displaying a new connector, the Locator View is showing a different section of the aircraft, and the
Wire List View and Pin List View have been updated to display new wiring data as well.

Click on
this wire!

Selecting A New Wire
Note also that all fields displayed with blue text in the Wire List View or Pin List View are "hot" and
selectable simply by clicking on them with the mouse. This includes “From RefDes/Pin”, “Wire”, and
“To RefDes/Pin”. Clicking on these table entries will change focus in the same manner that clicking
on the wire in the Wire Diagram View did. For additional details, see the Wiring on-line Help,
accessed by selecting “Wiring Illuminator Help” from the Help menu of the Context View window.
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Aircraft Configuration Examples
Wiring Illuminator displays the wiring in all of its views as it exists for a given aircraft and aircraft
configuration. Consequently, as you would expect, different configurations of the same aircraft may
have wiring differences that should be reflected in Wiring Illuminator. The following examples
demonstrate this.

Retrofit Configuration
This first example will show the change to the wiring of an aircraft that resulted from a retrofit to an
aircraft that resulted in a wiring change. You will see some of the wiring changes that were made to an
aircraft based upon the “AFC_001” configuration item.
1) Shut down Wiring Illuminator if you already have it up - select Exit from the File menu in the
Context View.
2) Restart Wiring Illuminator by double clicking on the Wiring Illuminator icon on your desktop.
3) Using the Window menu in the Context View, bring up the Wire Diagram, Wire List, and Pin
List views, as a minimum. (These may already be displayed.)
4) Enter the number 165454 in the Tail Number field of the Context View and then hit the Enter
key on your keyboard. Enter L200A22 in the Wire field of the Context View. Select the OK
button. Shown below is the Wire Diagram View that is displayed as a result.

5) Bring up the Aircraft Configuration View. (From the “Window” menu in the Context View.)
6) For the "AFC_001" Configuration Item, change its current value to "true" (click the Current
Value - a choice of "true" or "false" will be made available, select "true").
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7) Press the "Apply" button. (This applies the change, but does not dismiss the Aircraft
Configuration View. Pressing the OK button would apply the changes and dismiss the view.)
8) Notice that as shown in the screen shot below, the Wire Diagram has gotten more complex,
with the addition of two new wires – L200C22 and L200D22. Also notice that the Wire List
View has gone from listing the two wires "L200A22", and "L200B22" to now listing four
wires, "L200A22" up to "L200D22".

Two new wires
for AFC_001
Configuration
Item
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Change Incorporated During Manufacturing
The previous example shows a retrofit configuration – a wiring change that was made after the aircraft
was put into service. Later models may have such a change manufactured in.
Tail Number 234000 is an aircraft that had the wiring change from the previous example incorporated
when the aircraft was manufactured, rather than as a retrofit. Execute the following steps to see this.
1) Shut down Wiring Illuminator if you already have it up - select Exit from the File menu in the
Context View.
2) Restart Wiring Illuminator by double clicking on the Wiring Illuminator icon on your desktop.
3) Using the Window menu in the Context View, bring up the Wire Diagram, Wire List, and Pin
List views, as a minimum. (These may already be displayed.)
4) Enter the number 234000 in the Tail Number field of the Context View and then hit the Enter
key on your keyboard. Enter L200A22 in the Wire field of the Context View. Select the OK
button. Shown below is the Wire Diagram View that is displayed as a result

Note that the Wire Diagram View for aircraft 234000 shows the additional two wires (L200C22 and
L200D22) without having to select a retrofit Configuration Item from the Configuration Item View.
This is unlike aircraft 165454 for which you had to select the AFC_001 Configuration Item in order to
see these wires. This indicates that the additional two wires were installed when aircraft 234000 was
manufactured, as opposed to being a retrofit change.
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Getting More Information
This “Quick Start” tour of Wiring Illuminator should have given you a brief look at how Wiring
Illuminator can simplify maintenance tasks by replacing paper wiring diagrams with electronic
diagrams. If you have questions about Wiring Illuminator and how it works, see the online Help
function, or consult the Wiring Illuminator Users Manual that was installed on your computer
(C:\wi\FMSDEMO_WI\data\documents) along with the software.
Additionally, please contact Continental DataGraphics if you have any questions that are not covered
in the product documentation, including inquiries about product pricing.

Continental DataGraphics
15400 SE 30th Place, Suite 100
Bellevue, WA 98007
http://www.ietm.biz
(425) 456-0500
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